به روزرسانی وردپرس از طریقmartinibuster

og-image-inserted “>

تیم توسعه دهنده وردپرس ، در یک سری اقدامات اشتباه ، یک به روزرسانی معیوب را نصب کرد که نصب سایت های جدید وردپرس را غیرممکن می کرد. آنها در تلاش برای رفع این به روزرسانی مکالمه به روزرسانی را متوقف کردند اما این مشکلات حتی بیشتر ایجاد کرد ، برای رفع همه مشکلات نیاز به یک به روزرسانی اضطراری است.

نادرست وردپرس 5.5.2 به روز رسانی امنیتی این مأموریت در 29 اکتبر سال 2020 با به روزرسانی معمول برای رسیدگی به مسائل مهم امنیتی آغاز شد. وردپرس 5.5.2 به منظور جلوگیری از مسائلی مانند Cross Site Request Forgeries ، حملات XSS (Cross Site Scripting) و موارد دیگر بود.

متأسفانه ، این به روزرسانی نیز با ایجاد یک اشکال باعث عدم نصب جدید وردپرس شد. وردپرس اشکال را اینگونه توضیح داد:

“WordPress 5.5.2 … نصب وردپرس را در یک وب سایت کاملاً جدید که اتصال پایگاه داده پیکربندی نشده را غیرممکن می کند. این نسخه تأثیری بر سایتهایی که اتصال پایگاه داده از قبل پیکربندی شده است ، ندارد ، به عنوان مثال از طریق نصب کنندگان یک کلیک یا پرونده wp-config.php موجود. “

برای حل این مشکل ، وردپرس نسخه را متوقف کرد 5.5.2 از راه اندازی به سایت های بیشتر. و این زمانی است که یک به روزرسانی سرکش خود را به طور خودکار از بین برد.

تبلیغات

ادامه مطلب را در زیر بخوانید

وردپرس آلفا بروزرسانی به طور تصادفی بیرون رانده شد

وردپرس ترمزهای بروزرسانی های بعدی را ایجاد می کند. اما در حالی که تیم وردپرس به منظور آماده سازی وردپرس 5.5.3 به منظور رفع اشکال قبلی مشغول بودند ، به روزرسانی خودکار وردپرس از ابتدا دوباره شروع شد.

اما به دلیل غیرفعال بودن نسخه 5.5.2 ، سیستم خودکار وردپرس نسخه آلفای وردپرس را برای بارگیری و نصب در تاریخ 29 اکتبر انتخاب کرد. این نسخه آلفا قرار نبود نصب شود و دارای مشکلاتی باشد.

وردپرس 5.5.3 اشکالات آلفا

مسئله ای که در نصب آلفا وردپرس وجود داشت این بود که مضامین اضافی وردپرس را معرفی کرد و Akismet را نصب کرد. .

ظاهراً در این مضامین مشکلی وجود ندارد. اما ناشران که حذف آنها را انتخاب می کنند ، مجبور هستند که آنها را به روز کنند. عدم بروزرسانی این مضامین می تواند در آینده خطر امنیتی داشته باشد.

طبق اعلام وردپرس:

“اوایل امروز سیستم به روزرسانی خودکار برای وردپرس برخی سایت ها را از نسخه 5.5.2 به نسخه 5.5.3-alpha به روز کرد. این به دلیل خطایی بود که در اثر آماده سازی برای انتشار 5.5.3 ایجاد شده بود.

نسخه 5.5.3-alpha در این مرحله از نظر عملکرد با 5.5.2 یکسان بود زیرا هیچ کار توسعه ای در این زمینه آغاز نشده بود 5.5.3 ، با این حال ممکن است تغییرات زیر اعمال شده باشد:

پیش فرض “بیست” تم به عنوان بخشی از بسته پیش از انتشار نصب شده است. افزونه “Akismet” به عنوان بخشی از بسته پیش از انتشار نصب شده است. “

تبلیغات

< span> ادامه مطلب را در زیر بخوانید

یک صفحه وب ، ظاهراً برای انتشار آلفا ، در تاریخ 29 اکتبر سال 2020 منتشر شد ، ظاهراً به اشتباه نسخه 5.4.3 نامگذاری شده است. من به اشتباه می گویم زیرا وردپرس 5.4 در مارس 2020 منتشر شد و منطقی نیست که از وردپرس 5.5 به نسخه 5.4 برگردید.

صفحه بروزرسانی به ظاهر اشتباه 5.4.3 حاوی مستنداتی است که یکسان است اطلاعات منتشر شده برای نسخه 5.5.2

وردپرس 5.5.3

آخرین به روزرسانی ، نسخه 5.5.3 همان چیزی است که نسخه 5.5.2 قرار بود فقط بدون مشکلات مرتبط باشد . وردپرس 5.5.3 تمام مشکلات معرفی شده در نسخه 5.5.2 را برطرف می کند.

وردپرس توضیح داد:

«این نسخه نگهداری مشکلی را که در وردپرس معرفی شده بود برطرف می کند 5.5.2 که نصب وردپرس را در یک وب سایت کاملاً جدید که اتصال بانک اطلاعاتی پیکربندی نشده را غیرممکن می کند. این نسخه تاثیری روی سایتهایی که اتصال پایگاه داده از قبل پیکربندی شده است ، نمی باشد ، به عنوان مثال از طریق نصب کنندگان یک کلیک یا پرونده wp-config.php موجود.

اگر در 5.5.2 استفاده نمی کنید یا به روزرسانی خودکار برای انتشارهای جزئی غیرفعال است ، لطفاً با بارگیری وردپرس 5.5.3 یا بازدید از داشبورد → Updates ، دستی به نسخه 5.5.3 به روز کنید و روی “اکنون به روز کنید” کلیک کنید. “

What Wrong Wrong

مشکلات توسط تیم توسعه دهنده مطرح شد زیرا هیچ اسناد رسمی در مورد نحوه توقف به روزرسانی وردپرس وجود نداشت. به همین دلیل ، تیم وردپرس به روزرسانی را متوقف کردند به گونه ای که در را برای شروع نسخه آلفا باز می کرد.

این مسئله برطرف شده است تا این سناریو دیگر تکرار نشود.

با توجه به پست رسمی مشخصات فنی:

““ این کار دیگر انجام نمی شود. اکنون به نظر می رسد زمان مناسبی برای ثبت روش صحیح و صحیح “متوقف کردن” انتشار در حال انجام است که صادقانه قبلاً تلاش نشده بود. متوقف کردن انتشار در صورتی که تغییر درستی ایجاد کرده باشند بسیار ساده است ، بنابراین گرچه تلاش آنها یک فرض منطقی برای ایجاد بود ، اما این اشتباه بود.

سیستم انتشار پیچیده است و تلاش برای انجام آن مواردی که پیش بینی و مستند نشده است منجر به نتایج غیر منتظره می شود. این امر از طریق مستندسازی و کد بهتر و مدیریت خود سیستم انتشار بهبود می یابد. “

تبلیغات

ادامه مطلب را در زیر ادامه دهید

نصب وردپرس خود را بررسی کنید

ناشران توصیه می شوند که از بروزرسانی آنها به نسخه 5.5.3 مطمئن شوند. نسخه های قبل از 5.5.2 حاوی مشکلات امنیتی هستند ، بنابراین بسیار مهم است که آنها را به آخرین نسخه به روز کنید.

نسخه نگهداری وردپرس 5.5.3 هیچ عذرخواهی برای این مشکلات ندارد ، فقط “تشکر و تشکر” تیم توسعه برای رفع مشکلاتی که آنها معرفی کرده اند.