پاسخ وردپرس به به روزرسانی های پلاگین Rogue

WordPress.org بیانیه ای به توسعه دهندگان افزونه صادر کرد تا به تصمیمات کاربران در مورد به روزرسانی خودکار احترام بگذارند. این یادآوری پس از آن انجام می شود که ناشران افزونه All in One SEO به روزرسانی خودکار را بدون درخواست مجوز روشن کردند.

در این بیانیه هشدار داده شده است که افرادی که کاربران را در مورد بروزرسانی خودکار ابراز تمایل می کنند ، توسط WordPress.org پرچم گذاری می شوند.

به روز رسانی خودکار وردپرس

به روزرسانی خودکار ویژگی در سیستم مدیریت محتوای وردپرس (CMS) است که به کاربر اجازه می دهد انتخاب کند تا به یک افزونه اجازه بروزرسانی خودکار را بدهد.

این ویژگی با انتشار نسخه وردپرس 5.5 به راحتی در دسترس قرار گرفت.

این ویژگی همچنین به ناشران امکان انتخاب عدم دریافت به روزرسانی خودکار را می دهد

به روزرسانی خودکار افزونه ها سالهاست که یک ویژگی مخفی است. ناشرانی که قبلاً می خواستند به روزرسانی خودکار را فعال کنند ، مجبور بودند کد را در پرونده های پیکربندی خود تغییر دهند.

تبلیغات

ادامه مطلب را در زیر بخوانید

کاری که به روزرسانی خودکار انجام می دهد تسهیل در اختیار داشتن ناشر برای آخرین نسخه از پلاگین های خود است. این می تواند مهم باشد زیرا برخی از به روزرسانی ها حاوی رفع آسیب پذیری هستند. عدم بروزرسانی برخی از افزونه ها می تواند منجر به تصرف یک سایت توسط یک هکر مخرب شود.

نکته منفی به روزرسانی های خودکار این است که به روزرسانی خراب شود و باعث درگیری ناخواسته با افزونه ها یا مضامین دیگر شود.

مطالب پیشنهادی  گوگل با افشای داده های جستجو و موارد دیگر روز ملی دوستداران کتاب را جشن می گیرد

به همین دلیل است که بسیاری از ناشران ترجیح می دهند افزونه های خود را به صورت کنترل شده به روز کنند تا بلافاصله از هر مشکلی مطلع شوند.

همه در یک به روز رسانی خودکار جستجوگرها

در اواخر نوامبر سال 2020 ، ناشران افزونه All in One SEO به نسخه 4 به روزرسانی شدند و در برخی موارد بدون درخواست اجازه کاربر به طور یک جانبه به روزرسانی خودکار افزونه خود را روشن کردند.

تبلیغات

ادامه مطلب را در زیر بخوانید

این حتی برای ناشران که اصرار زیادی داشتند که به روزرسانی خودکار را روشن نکرده اند ، اتفاق افتاد.

اطلاعات بیشتر در اینجا ، وردپرس همه در یک به روزرسانی خودکار سئو باعث واکنش شدید می شود

اخطارهای وردپرس درباره به روزرسانی های خودکار

گرچه ممکن است All in One SEO تنها افزونه فعال کردن به روزرسانی خودکار نباشد ، اما مطمئناً محبوب ترین سازنده افزونه است که از زمان معرفی WordPress 5.5 این کار را انجام داده است.

وردپرس با انتشار بیانیه ای رسمی ، به انجمن توسعه نرم افزار افزونه یادآوری کرد که نباید بدون اجازه صریح کاربران ، به روزرسانی خودکار را روشن کنند.

طبق وردپرس:

“شما ممکن است یک ویژگی را برای به روزرسانی خودکار ارائه دهید ، اما باید از تنظیمات اصلی آن تبعیت کند. این بدان معناست که اگر کسی سایت خود را روی “هرگز هیچ یک از افزونه ها یا طرح های زمینه من را به روز نکنید” تنظیم کرده باشید ، شما مجبور نیستید که این موارد را برای آنها تغییر دهید مگر اینکه آنها شرکت کنند و آن را درخواست نکنند.

دلیل این امر این است که افزونه ها نباید بیش از حد مجاز باشند. “

در این اطلاعیه همچنین آمده است که به روزرسانی های خودکار می تواند نتایج غیر منتظره ای را در وب سایت های ناشران ایجاد کند و بر اعتمادی که ناشران به توسعه دهندگان پلاگین و خود وردپرس دارند تأثیر بگذارد.

مطالب پیشنهادی  گوگل برخی از SERP ها را با نتایج ترجمه شده به روز می کند

در آنچه به نظر می رسد اشاره به مسئله اخیر افزونه All in One SEO است ، بیانیه وردپرس آن را ناراحت کننده خواند.

“متأسفانه ، این اتفاق اخیراً برای یک افزونه خوب استفاده شده رخ داده است و نتایج بسیار ناگوار بوده است.”

در ادامه این بیانیه اشاره شد که هیچ برنامه ای برای ایجاد یک راهنمای رسمی در مورد این موضوع وجود ندارد ، اما وردپرس به “پرچم گذاری” افزونه هایی که اعتماد و خواسته کاربر را در رابطه با به روزرسانی خودکار پلاگین ها نقض می کند ، ادامه خواهد داد.

استناد

یادآوری: افزونه ها نباید با بروزرسانی ها تداخل داشته باشند

سئو PBN | خبر های جدید سئو و هک و سرور