آسیب پذیری افزونه سازگاری با GDPR وردپرس Complianz

یک افزونه محبوب وردپرس برای رعایت حریم خصوصی با بیش از 800000 نصب اخیراً یک آسیب‌پذیری ذخیره‌شده XSS را اصلاح کرده است که می‌تواند به مهاجم اجازه دهد تا اسکریپت‌های مخرب را برای حمله به بازدیدکنندگان سایت آپلود کند.

Complianz | افزونه وردپرس موافقت با کوکی GDPR/CCPA

افزونه Complianz برای وردپرس ابزار قدرتمندی است که به صاحبان وب سایت کمک می کند تا از مقررات حفظ حریم خصوصی مانند مقررات حفاظت از داده های عمومی (GDPR) و قانون حفظ حریم خصوصی مصرف کنندگان کالیفرنیا (CCPA) پیروی کنند.

این افزونه چندین جنبه از حریم خصوصی کاربر از جمله مسدود کردن کوکی‌های شخص ثالث، مدیریت رضایت کوکی (از جمله در هر منطقه فرعی)، و مدیریت چندین جنبه مربوط به بنرهای کوکی را مدیریت می‌کند.

تطبیق پذیری و مفید بودن آن ممکن است دلیل محبوبیت ابزاری باشد که در حال حاضر بیش از 800000 نصب دارد.

آسیب پذیری XSS ذخیره شده افزونه Complianz

افزونه Complianz WordPress دارای یک آسیب پذیری ذخیره شده XSS است که نوعی آسیب پذیری است که به کاربر اجازه می دهد یک اسکریپت مخرب را مستقیماً در سرور وب سایت آپلود کند. بر خلاف XSS منعکس شده که کاربر وب سایت را ملزم به کلیک بر روی پیوند می کند، XSS ذخیره شده شامل یک اسکریپت مخرب است که از سرور وب سایت مورد نظر ذخیره و ارائه می شود.

این آسیب پذیری در تنظیمات مدیریت Complianz است که به صورت عدم وجود دو عملکرد امنیتی است.

1. پاکسازی ورودی
این افزونه فاقد پاکسازی ورودی کافی و خروجی خروجی بود. پاکسازی ورودی یک فرآیند استاندارد برای بررسی ورودی‌های یک وب‌سایت است، مانند یک فیلد فرم، تا مطمئن شود آنچه ورودی است همان چیزی است که انتظار می‌رود، مانند ورودی متن در مقابل آپلود اسکریپت.

راهنمای رسمی توسعه دهندگان وردپرس پاکسازی داده ها را به صورت زیر توصیف می کند:

“ورودی ضدعفونی کننده فرآیند ایمن سازی/تمیز کردن/فیلتر کردن داده های ورودی است. اعتبار سنجی بر ضدعفونی ترجیح داده می شود زیرا اعتبارسنجی خاص تر است. اما زمانی که «مشخص تر» امکان پذیر نباشد، پاکسازی بهترین کار بعدی است.»

2. خروجی فرار
این افزونه فاقد Output Ecaping است که یک فرآیند امنیتی است که داده‌های ناخواسته را قبل از رندر شدن برای کاربر حذف می‌کند.

آسیب پذیری چقدر جدی است؟

این آسیب‌پذیری مستلزم آن است که مهاجم سطوح مجوز مدیریت و بالاتر را برای اجرای حمله دریافت کند. به همین دلیل است که این آسیب پذیری امتیاز 4.4 از 10 را به خود اختصاص داده است که ده نشان دهنده بالاترین سطح آسیب پذیری است.

این آسیب پذیری فقط بر انواع خاصی از تاسیسات نیز تاثیر می گذارد.

به گزارش Wordfence:

این امکان را برای مهاجمان احراز هویت شده با مجوزهای سطح سرپرست و بالاتر فراهم می‌کند تا اسکریپت‌های وب دلخواه را در صفحاتی تزریق کنند که هر زمان که کاربر به صفحه‌ای تزریق شده دسترسی پیدا کند، اجرا می‌شوند.

این فقط بر نصب‌های چند سایتی و نصب‌هایی که unfiltered_html غیرفعال شده است تأثیر می‌گذارد.»

به روز رسانی به آخرین نسخه

این آسیب پذیری بر نسخه های Complianz برابر یا کمتر از نسخه 6.5.5 تأثیر می گذارد. به کاربران توصیه می شود به نسخه 6.5.6 یا بالاتر به روز رسانی کنند.

توصیه Wordfence در مورد آسیب پذیری را بخوانید:

Complianz | رضایت کوکی GDPR/CCPA <= 6.5.5 - اسکریپت بین سایتی ذخیره شده تأیید شده (Administrator+) از طریق تنظیمات